Unable To Connect To Rockstar Game Services Server Support Cfxre Community

From SEDS-USA Wiki
Jump to navigation Jump to search

SOLVED - Look at “Edit #2” below for my solution.



Server Artifact Version: 1953 (I have even tried 1911, the recommended build) Operating System (Windows/Linux): Linux Error screenshot (if any): https://i.imgur.com/7Z6n6AT.png Server config (server.cfg): https://pastebin.com/UikYTBnB Path to server files: /home/rdrserver/redm/server_files Path to cfx-server-data files: /home/rdrserver/redm/server_data



Console screenshot: https://i.imgur.com/u1LhQ3y.png



Describe your issue: I’m having issues getting into my RedM server. I’m getting the “Unable to connect to Rockstar game services” message. Gaming blog It worked 12 hours ago, and I haven’t changed anything in the server config.



What have you tried?: I checked the fivem license key and the steam web api key, all is well there. I reinstalled the RedM client on my PC, I redownloaded the latest version of cfx-server-data from github for my server. Gaming blog I downloaded the latest recommended master branch build (build 1911) of artifacts server files. Yet I’m getting the “Unable to connect to Rockstar game services”. Not sure how to troubleshoot this further, any ideas? I tried with the newest build as well (build 1953), and I still get the same error message, just like I did with the 1911 build. I have the rockstar launcher up and running, and I have tried with Steam running as well, since that’s where I bought the game. None of it works.



I have tried adding “ensure sessionmanager” and “ensure webadmin” to the config. I have also tried adding “stop sessionmanager” and “stop webadmin” in the config, didn’t work either.



Appreciate any help I can get, thanks people!



Edit: Also! I have tried joining other random servers through RedM, and it’s working just fine. As well as Red Dead Online, all of it is working as intended. It’s just my server that I’m getting the error message on.



Edit #2 - SOLUTION: It is working just fine now! So apparently I was starting the server from the wrong directory. I just had to make sure that when I start the server, the server needs to be able to find server_data. Silly noob mistake.